diff --git a/packages/device_info_plus/device_info_plus_aurora/.gitignore b/packages/device_info_plus/device_info_plus_aurora/.gitignore
new file mode 100644
index 0000000..96486fd
--- /dev/null
+++ b/packages/device_info_plus/device_info_plus_aurora/.gitignore
@@ -0,0 +1,30 @@
+# Miscellaneous
+*.class
+*.log
+*.pyc
+*.swp
+.DS_Store
+.atom/
+.buildlog/
+.history
+.svn/
+migrate_working_dir/
+
+# IntelliJ related
+*.iml
+*.ipr
+*.iws
+.idea/
+
+# The .vscode folder contains launch configuration and tasks you configure in
+# VS Code which you may wish to be included in version control, so this line
+# is commented out by default.
+#.vscode/
+
+# Flutter/Dart/Pub related
+# Libraries should not include pubspec.lock, per https://dart.dev/guides/libraries/private-files#pubspeclock.
+/pubspec.lock
+**/doc/api/
+.dart_tool/
+.packages
+build/
diff --git a/packages/device_info_plus/device_info_plus_aurora/README.md b/packages/device_info_plus/device_info_plus_aurora/README.md
new file mode 100644
index 0000000..b85db91
--- /dev/null
+++ b/packages/device_info_plus/device_info_plus_aurora/README.md
@@ -0,0 +1,55 @@
+# device_info_plus_aurora
+
+The Aurora implementation of [`device_info_plus`](https://pub.dev/packages/device_info_plus).
+
+Permission: `DeviceInfo`.
+
+Information available:
+
+- `id` - Target platform.
+- `name` - Name OS.
+- `version` - Versions OS.
+- `prettyName` - Name and version OS.
+- `hasGNSS` - The presence of GNSS in the device.
+- `hasNFC` - The presence of NFC in the device.
+- `hasBluetooth` - The presence of bluetooth in the device.
+- `hasWlan` - The presence of wlan in the device.
+- `maxCpuClockSpeed` - Max CPU clock speed.
+- `numberCpuCores` - Number CPU cores.
+- `batteryChargePercentage` - Device battery charge percentage.
+- `mainCameraResolution` - Device main camera resolution.
+- `frontalCameraResolution` - Device frontal camera resolution.
+- `ramTotalSize` - Size total ram.
+- `ramFreeSize` - Size free ram.
+- `screenResolution` - Device screen resolution.
+- `osVersion` - Name and version OS.
+- `deviceModel` - Device name model.
+- `internalStorage` - Map with information on internal storage.
+- `internalStorage` - Map with information on internal storage.
+- `simCards` - Array with information about SIM cards.
+
+## Usage
+
+This package is not an _endorsed_ implementation of `device_info_plus`.
+Therefore, you have to include `device_info_plus_aurora` alongside `device_info_plus` as dependencies in your `pubspec.yaml` file.
+
+**pubspec.yaml**
+
+```yaml
+dependencies:
+ device_info_plus: ^9.0.1
+ device_info_plus_aurora:
+ path: # path to folder with plugin
+```
+
+***.dart**
+
+```dart
+import 'package:device_info_plus/device_info_plus.dart';
+
+final deviceInfoPlugin = DeviceInfoPlugin();
+final deviceInfo = await deviceInfoPlugin.linuxInfo as AuroraDeviceInfo;
+
+debutPrint(deviceInfo.data);
+```
+
diff --git a/packages/device_info_plus/device_info_plus_aurora/analysis_options.yaml b/packages/device_info_plus/device_info_plus_aurora/analysis_options.yaml
new file mode 100644
index 0000000..566c597
--- /dev/null
+++ b/packages/device_info_plus/device_info_plus_aurora/analysis_options.yaml
@@ -0,0 +1,4 @@
+# Copyright (c) 2023. Open Mobile Platform LLC.
+# License: Proprietary.
+
+include: package:flutter_lints/flutter.yaml
diff --git a/packages/device_info_plus/device_info_plus_aurora/data/preview.png b/packages/device_info_plus/device_info_plus_aurora/data/preview.png
new file mode 100644
index 0000000..b7d356e
Binary files /dev/null and b/packages/device_info_plus/device_info_plus_aurora/data/preview.png differ
diff --git a/packages/device_info_plus/device_info_plus_aurora/data/ru.omp.deviceinfo.Features.xml b/packages/device_info_plus/device_info_plus_aurora/data/ru.omp.deviceinfo.Features.xml
new file mode 100644
index 0000000..3c38d5a
--- /dev/null
+++ b/packages/device_info_plus/device_info_plus_aurora/data/ru.omp.deviceinfo.Features.xml
@@ -0,0 +1,59 @@
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
diff --git a/packages/device_info_plus/device_info_plus_aurora/data/ru.omp.deviceinfo.SIM.xml b/packages/device_info_plus/device_info_plus_aurora/data/ru.omp.deviceinfo.SIM.xml
new file mode 100644
index 0000000..0b2bc14
--- /dev/null
+++ b/packages/device_info_plus/device_info_plus_aurora/data/ru.omp.deviceinfo.SIM.xml
@@ -0,0 +1,21 @@
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
diff --git a/packages/device_info_plus/device_info_plus_aurora/data/ru.omp.deviceinfo.Storages.xml b/packages/device_info_plus/device_info_plus_aurora/data/ru.omp.deviceinfo.Storages.xml
new file mode 100644
index 0000000..d7fbd32
--- /dev/null
+++ b/packages/device_info_plus/device_info_plus_aurora/data/ru.omp.deviceinfo.Storages.xml
@@ -0,0 +1,21 @@
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
diff --git a/packages/device_info_plus/device_info_plus_aurora/example/.gitignore b/packages/device_info_plus/device_info_plus_aurora/example/.gitignore
new file mode 100644
index 0000000..3db3823
--- /dev/null
+++ b/packages/device_info_plus/device_info_plus_aurora/example/.gitignore
@@ -0,0 +1,47 @@
+# Miscellaneous
+*.class
+*.log
+*.pyc
+*.swp
+.DS_Store
+.atom/
+.buildlog/
+.history
+.svn/
+migrate_working_dir/
+
+# IntelliJ related
+*.iml
+*.ipr
+*.iws
+.idea/
+
+# The .vscode folder contains launch configuration and tasks you configure in
+# VS Code which you may wish to be included in version control, so this line
+# is commented out by default.
+#.vscode/
+
+# Flutter/Dart/Pub related
+**/doc/api/
+**/ios/Flutter/.last_build_id
+.dart_tool/
+.flutter-plugins
+.flutter-plugins-dependencies
+.packages
+.pub-cache/
+.pub/
+/build/
+
+# Symbolication related
+app.*.symbols
+
+# Obfuscation related
+app.*.map.json
+
+# Android Studio will place build artifacts here
+/android/app/debug
+/android/app/profile
+/android/app/release
+
+# Aurora generated
+/aurora/flutter
diff --git a/packages/device_info_plus/device_info_plus_aurora/example/README.md b/packages/device_info_plus/device_info_plus_aurora/example/README.md
new file mode 100644
index 0000000..ae0d7d1
--- /dev/null
+++ b/packages/device_info_plus/device_info_plus_aurora/example/README.md
@@ -0,0 +1,21 @@
+# device_info_plus_aurora
+
+Demonstrates how to use the device_info_plus plugin.
+
+## Build
+
+```shell
+# Add an alias if it doesn't already exist
+alias flutter-aurora=$HOME/.local/opt/flutter-sdk/bin/flutter
+# Get dependencies
+flutter-aurora pub get
+# Run build
+flutter-aurora build aurora --release # [--release|--debug|--profile]
+```
+
+You can collect, sign, run an example on the device with a script located in the `script/build_example.sh`
+More information in `build_example.sh`.
+
+### Preview example
+
+![preview.png](../data/preview.png)
diff --git a/packages/device_info_plus/device_info_plus_aurora/example/analysis_options.yaml b/packages/device_info_plus/device_info_plus_aurora/example/analysis_options.yaml
new file mode 100644
index 0000000..566c597
--- /dev/null
+++ b/packages/device_info_plus/device_info_plus_aurora/example/analysis_options.yaml
@@ -0,0 +1,4 @@
+# Copyright (c) 2023. Open Mobile Platform LLC.
+# License: Proprietary.
+
+include: package:flutter_lints/flutter.yaml
diff --git a/packages/device_info_plus/device_info_plus_aurora/example/aurora/.gitignore b/packages/device_info_plus/device_info_plus_aurora/example/aurora/.gitignore
new file mode 100644
index 0000000..d3896c9
--- /dev/null
+++ b/packages/device_info_plus/device_info_plus_aurora/example/aurora/.gitignore
@@ -0,0 +1 @@
+flutter/ephemeral
diff --git a/packages/device_info_plus/device_info_plus_aurora/example/aurora/CMakeLists.txt b/packages/device_info_plus/device_info_plus_aurora/example/aurora/CMakeLists.txt
new file mode 100644
index 0000000..ef6d32e
--- /dev/null
+++ b/packages/device_info_plus/device_info_plus_aurora/example/aurora/CMakeLists.txt
@@ -0,0 +1,50 @@
+# Copyright (c) 2023. Open Mobile Platform LLC.
+# License: Proprietary.
+
+cmake_minimum_required(VERSION 3.10)
+project(com.example.device_info_plus_aurora_example LANGUAGES CXX)
+
+include(GNUInstallDirs)
+
+set(BINARY_NAME ${CMAKE_PROJECT_NAME})
+set(FLUTTER_DIR ${CMAKE_CURRENT_SOURCE_DIR}/flutter)
+
+set(CMAKE_CXX_STANDARD 17)
+set(CMAKE_CXX_STANDARD_REQUIRED ON)
+
+set(CMAKE_CXX_FLAGS "-Wall -Wextra")
+set(CMAKE_CXX_FLAGS_RELEASE "-O3")
+
+set(CMAKE_SKIP_RPATH OFF)
+set(CMAKE_INSTALL_RPATH "\$ORIGIN/../share/${BINARY_NAME}/lib")
+
+find_package(PkgConfig REQUIRED)
+pkg_check_modules(FlutterEmbedder REQUIRED IMPORTED_TARGET flutter-embedder)
+
+add_executable(${BINARY_NAME} main.cpp ${FLUTTER_DIR}/generated_plugin_registrant.cpp)
+target_link_libraries(${BINARY_NAME} PRIVATE PkgConfig::FlutterEmbedder)
+target_include_directories(${BINARY_NAME} PRIVATE ${FLUTTER_DIR})
+
+include(flutter/generated_plugins.cmake)
+
+set(PACKAGE_INSTALL_DIR ${CMAKE_INSTALL_DATADIR}/${BINARY_NAME})
+set(DESKTOP_INSTALL_DIR ${CMAKE_INSTALL_DATADIR}/applications)
+set(ICONS_INSTALL_ROOT_DIR ${CMAKE_INSTALL_DATADIR}/icons/hicolor)
+
+add_custom_command(TARGET ${BINARY_NAME} POST_BUILD
+ COMMAND ${CMAKE_COMMAND} -E copy
+ ${CMAKE_INSTALL_PREFIX}/${CMAKE_INSTALL_LIBDIR}/libflutter-embedder.so
+ ${PROJECT_BINARY_DIR}/bundle/lib/libflutter-embedder.so)
+
+install(FILES ${PROJECT_BINARY_DIR}/bundle/icudtl.dat DESTINATION ${PACKAGE_INSTALL_DIR})
+install(DIRECTORY ${PROJECT_BINARY_DIR}/bundle/flutter_assets DESTINATION ${PACKAGE_INSTALL_DIR})
+install(DIRECTORY ${PROJECT_BINARY_DIR}/bundle/lib DESTINATION ${PACKAGE_INSTALL_DIR})
+
+install(TARGETS ${BINARY_NAME} RUNTIME DESTINATION ${CMAKE_INSTALL_BINDIR})
+install(FILES desktop/${BINARY_NAME}.desktop DESTINATION ${DESKTOP_INSTALL_DIR})
+
+foreach(ICONS_SIZE 86x86 108x108 128x128 172x172)
+ install(FILES icons/${ICONS_SIZE}.png
+ RENAME ${BINARY_NAME}.png
+ DESTINATION ${ICONS_INSTALL_ROOT_DIR}/${ICONS_SIZE}/apps/)
+endforeach(ICONS_SIZE)
diff --git a/packages/device_info_plus/device_info_plus_aurora/example/aurora/desktop/com.example.device_info_plus_aurora_example.desktop b/packages/device_info_plus/device_info_plus_aurora/example/aurora/desktop/com.example.device_info_plus_aurora_example.desktop
new file mode 100644
index 0000000..88c8b51
--- /dev/null
+++ b/packages/device_info_plus/device_info_plus_aurora/example/aurora/desktop/com.example.device_info_plus_aurora_example.desktop
@@ -0,0 +1,12 @@
+[Desktop Entry]
+Type=Application
+Name=device_info_plus_aurora_example
+Comment=Demonstrates how to use the device_info_plus_aurora plugin.
+Icon=com.example.device_info_plus_aurora_example
+Exec=/usr/bin/com.example.device_info_plus_aurora_example
+X-Nemo-Application-Type=silica-qt5
+
+[X-Application]
+Permissions=DeviceInfo
+OrganizationName=com.example
+ApplicationName=device_info_plus_aurora_example
diff --git a/packages/device_info_plus/device_info_plus_aurora/example/aurora/icons/108x108.png b/packages/device_info_plus/device_info_plus_aurora/example/aurora/icons/108x108.png
new file mode 100644
index 0000000..984893d
Binary files /dev/null and b/packages/device_info_plus/device_info_plus_aurora/example/aurora/icons/108x108.png differ
diff --git a/packages/device_info_plus/device_info_plus_aurora/example/aurora/icons/128x128.png b/packages/device_info_plus/device_info_plus_aurora/example/aurora/icons/128x128.png
new file mode 100644
index 0000000..2d552ef
Binary files /dev/null and b/packages/device_info_plus/device_info_plus_aurora/example/aurora/icons/128x128.png differ
diff --git a/packages/device_info_plus/device_info_plus_aurora/example/aurora/icons/172x172.png b/packages/device_info_plus/device_info_plus_aurora/example/aurora/icons/172x172.png
new file mode 100644
index 0000000..9dc271b
Binary files /dev/null and b/packages/device_info_plus/device_info_plus_aurora/example/aurora/icons/172x172.png differ
diff --git a/packages/device_info_plus/device_info_plus_aurora/example/aurora/icons/86x86.png b/packages/device_info_plus/device_info_plus_aurora/example/aurora/icons/86x86.png
new file mode 100644
index 0000000..5923bb1
Binary files /dev/null and b/packages/device_info_plus/device_info_plus_aurora/example/aurora/icons/86x86.png differ
diff --git a/packages/device_info_plus/device_info_plus_aurora/example/aurora/main.cpp b/packages/device_info_plus/device_info_plus_aurora/example/aurora/main.cpp
new file mode 100644
index 0000000..83f2ca8
--- /dev/null
+++ b/packages/device_info_plus/device_info_plus_aurora/example/aurora/main.cpp
@@ -0,0 +1,13 @@
+/*
+ * Copyright (c) 2023. Open Mobile Platform LLC.
+ * License: Proprietary.
+ */
+#include
+#include "generated_plugin_registrant.h"
+
+int main(int argc, char *argv[]) {
+ Application::Initialize(argc, argv);
+ RegisterPlugins();
+ Application::Launch();
+ return 0;
+}
diff --git a/packages/device_info_plus/device_info_plus_aurora/example/aurora/rpm/com.example.device_info_plus_aurora_example.spec b/packages/device_info_plus/device_info_plus_aurora/example/aurora/rpm/com.example.device_info_plus_aurora_example.spec
new file mode 100644
index 0000000..8706033
--- /dev/null
+++ b/packages/device_info_plus/device_info_plus_aurora/example/aurora/rpm/com.example.device_info_plus_aurora_example.spec
@@ -0,0 +1,31 @@
+%global __provides_exclude_from ^%{_datadir}/%{name}/lib/.*$
+%global __requires_exclude ^lib(dconf|flutter-embedder|maliit-glib|appmanifest-.+|.+_platform_plugin)\\.so.*$
+
+Name: com.example.device_info_plus_aurora_example
+Summary: Demonstrates how to use the device_info_plus_aurora plugin.
+Version: 0.1.0
+Release: 1
+License: Proprietary
+Source0: %{name}-%{version}.tar.zst
+
+BuildRequires: cmake
+BuildRequires: pkgconfig(flutter-embedder)
+
+%description
+%{summary}.
+
+%prep
+%autosetup
+
+%build
+%cmake -DCMAKE_BUILD_TYPE=%{_flutter_build_type}
+%make_build
+
+%install
+%make_install
+
+%files
+%{_bindir}/%{name}
+%{_datadir}/%{name}/*
+%{_datadir}/applications/%{name}.desktop
+%{_datadir}/icons/hicolor/*/apps/%{name}.png
diff --git a/packages/device_info_plus/device_info_plus_aurora/example/lib/main.dart b/packages/device_info_plus/device_info_plus_aurora/example/lib/main.dart
new file mode 100644
index 0000000..26c9b63
--- /dev/null
+++ b/packages/device_info_plus/device_info_plus_aurora/example/lib/main.dart
@@ -0,0 +1,389 @@
+/*
+ * Copyright (c) 2023. Open Mobile Platform LLC.
+ * License: Proprietary.
+ */
+import 'package:device_info_plus_aurora/aurora_device_info.dart';
+import 'package:flutter/material.dart';
+import 'dart:async';
+
+import 'package:device_info_plus/device_info_plus.dart';
+
+void main() {
+ runApp(const MyApp());
+}
+
+class MyApp extends StatefulWidget {
+ const MyApp({super.key});
+
+ @override
+ State createState() => _MyAppState();
+}
+
+class _MyAppState extends State {
+ String? _error;
+ String? _id;
+ String? _name;
+ String? _version;
+ String? _prettyName;
+ bool? _hasGNSS;
+ bool? _hasNFC;
+ bool? _hasBluetooth;
+ bool? _hasWlan;
+ int? _maxCpuClockSpeed;
+ int? _numberCpuCores;
+ int? _batteryChargePercentage;
+ double? _mainCameraResolution;
+ double? _frontalCameraResolution;
+ int? _ramTotalSize;
+ int? _ramFreeSize;
+ String? _screenResolution;
+ String? _osVersion;
+ String? _deviceModel;
+ Map? _externalStorage;
+ Map? _internalStorage;
+ List